Eachine Aurora 90 : ajout d’un récepteur Frsky XM

Le Eachine Aurora 90 est fourni avec un récepteur de télécommande (compatible FrSky dans mon cas).

Le récepteur Frsky se trouve sur l’element tout en haut du MiniCube F3 (ensemble ESC+contrôleur de vol+récepteur/buzzer qui propulse le quad).

Dès que j’ai eu cet engin entre les mains j’ai constaté quelques pertes de signal mais aussi des comportements étranges en vol comme des commandes ne répondant pas correctement. J’ai donc envie de remplacer le récepteur par quelque chose de plus fiable afin de voir si mon problème vient de là.

Pour commencer, en se référant au manuel du MiniCube F3, on constate que la connectique est très simple. 2 pins pour le buzzer et 3 pins pour le signal SBUS.

Pour cet « upgrade » je vais utiliser :

  • Un récepteur Frsky XM ou XM+ (très petit, fonctionne en SBUS, offre 16 canaux numériques mais pas de télémétrie).
  • Un mini-buzzer (attention, quelque chose de plus grand que ce modèle ne permettra plus de remettre la caméra FPV).

L’ensemble de l’opération prend 10-15 minutes, rien de compliqué. Pour ma part j’ai utilisé des composants recyclés (le XM vient d’un QX90 que j’avais upgradé, le buzzer s’est arraché sur mon 130mm).

Le démontage du récepteur est simple mais nécessite un peu de rapidité au fer à souder. il faut lever la plaque du récepteur tout en chauffant les 5 pins la retenant au contrôleur de vol situé en dessous. Un peu de patience et ça vient.

Le récepteur est démonté (notez le nom du contrôleur Halo F3, on est bien sur une copie du AXC Halo ;))
On va maintenant souder un buzzer et le récepteur Frsky XM.
On pourrait souder directement le récepteur XM sur les 3 pins SBUS mais on ne pourrait plus accéder au bouton « bind ». J’ai donc utilisé des fils.
Le récepteur est collé au MiniCube avec du double-face épais. L’ensemble loge parfaitement. J’ai également mis un peu de double-face sur les connecteurs SBUS afin de les protéger des coups, de l’herbe, etc.

Voici ce que ça donne une fois le quad re-assemblé.

Suite à l’upgrade il est nécessaire de re-binder le récepteur XM à la télécommande (en mode D16) et il ne reste plus qu’à tester. On pensera également à vérifier sous Betaflight Configurator que les canaux fonctionnent correctement, qu’ils sont centrés, etc.

28 réponses sur “Eachine Aurora 90 : ajout d’un récepteur Frsky XM”

    1. Mais sinon un truc à tester qui m’a permis de résoudre un problème comme ca sur un autre quad : changer le proto de communication des esc. L’aurora est en « DShot 600 » en principe. Essaye en « MultiShot 42 ».

      1. J’essairai je te remercie. J’ai le Aurora 100. Qq problèmes de flip. Qui ont entraîné d’ailleurs la perte du buzzer, la destruction de la caméra (assez moyenne par rapport au tx03) et arrachage des conducteurs du buzzer de la carte. Donc est ce que je reprends ce même minicube ou autre chose ?
        Qu’en penses tu ?

        1. ah oui en effet, c’est embêtant toute cette casse. Je sais pas quoi te dire. Le minicube est intéressant sur le papier et pour les quelques tests que j’ai fait. Par contre c’est tout nouveau et peut être pas super-fiable.

          Après le problème peut venir soit du récepteur (j’en doute pour le flip), soit du contrôleur de vol soit de l’esc 4-en-1. Donc pas mal de tests en perspective.

          On trouve de plus en plus de composants équivalents mais impossible de dire ce qu’ils valent vraiment.

          Les fips se produisent a quel moment ? (en vol d’un coup ou à l’atterrissage ?).

          Au niveau de la conso CPU (dans betaflight) c’est à combien ?

          Il faudrait aussi tester les vibrations moteur (via l’interface de betaflight, est-ce que sans hélices tu as beaucoup de vibrations ?)

          1. Cela m’est arrivé 2 fois de suite alors que je ne faisais qu’un simple virage léger en stabilisé en plein vol, tout a lâché d’un coup, mais malheureusement les 2 fois la chute a été sur le béton.
            Betaflight je ne maîtrise pas du tout mais je vais essayer de mettre le nez dedans alors.
            Je n’ai aucune vibration pour le moment. Je pense pouvoir raccorder le buzzer à la carte de vol. J’ai mis une tx03
            https://youtu.be/jkP0iyyId2A

            Affaire à suivre donc

          2. ça ressemble plus à une perte de signal radio. Dans la conf betaflight, failsafe. mets « hold » pour les gaz pour voir. Ca maintient le niveau de gaz pendant quelques instants avant de couper. si t’as une petite perte de signal ça évitera la chute.

    2. Bon, j’ai testé, avec le récepteur XM tout est ok pour moi. Plus de perte de signal ou d’absence de réponse aux commandes.

  1. c’est curieux que tu me dises perte de signal, car justement hier, c’est arrivé plusieurs fois alors que je n’étais pas loin, sans conséquence cette fois.
    est ce normal que cela soit si fréquent?
    pour le failsafe, je le ferai plus tard car un arbre a décidé de mettre un terme à la session et donc il lui manque un bras

    1. ah mince, désolé pour toi.

      C’est exactement ce que j’ai constaté et qui m’a fait tiquer :
      A courte portée je perds le signal avec le récepteur standard.

      A plus longue portée il répond pas toujours aux commandes (je donne du roulis mais il réagit pas par exemple).

    1. pour la taille et si tu es en Frsky comme moi je te recommande le XM ou XM+ (liens dans l’article). Ils sont fiables, petits mais sans télémétrie.

      Tu peux tenter de rentrer un Frsky XSR (https://www.banggood.com/FrSky-XSR-2_4GHz-16CH-ACCST-Receiver-S-Bus-CPPM-Output-Support-X9D-X9E-X9DP-X12S-X-Series-p-1031481.html) mais je te garantis pas que ça rentrera.

      je viens de regarder, à l’oeil nu c’est limite mais ça semble faisable le récepteur XSR mesure 20mm de large par 25mm de long (mais 30mm au niveau du connecteur).

      Tu peux raccorder la télémétrie sur le connecteur RX2/TX2 du FC du minicube (plaque du milieu) par contre contre c’est du S.Port (le fil télémétrie se raccorde à la fois sur TX et RX).

      Bref, je te recommande quand même le XM ou XM+ l’installation est beaucoup plus facile, t’as la place pour un buzzer, etc.

  2. Je vais prendre un XM ou XM+ alors je vais lancer ma commande.
    Tu maintiens ton antenne avec de la gaine thermorétractable?
    Merci encore pour tes conseils, décidément

  3. XM+ reçu et installé (sur Aurora 100) comme une fleur
    tout fonctionne nickel, plus du tout de chute et de coupure signal
    merci

    1. Content d’apprendre que ton problème est résolu.

      Moi de mon coté je m’arrache les cheveux avec l’Aurora, niveau signal c’est ok mais il fait plein de choses bizarres. Je pense que je vais le reconstruire avec un autre contrôleur de vol … 🙁

      1. Quel genre de trucs ?
        Moi je bute avec l’osd. J’avais changé le combo caméra vtx par le tx03 mais j’ai eu des pertes de signal donc j’ai voulu changer par le vtx03 et une petite caméra 1,2g super light (banggood). Mais le problème est que la connexion à l’osd ne passe pas. Sans passer par l’osd tout fonctionne. Si je bricole le tx03, l’osd passe sans problème. Tu as une petite idée ?

        1. Mais tu as bien repiqué video in et vidéo out, dans le bon ordre ?

          Sinon pour les problèmes que j’ai. J’ai fait un vol test et le quad à littéralement perdu les pédales et crashé violemment (désynchronisation des ESC ?). Suite à cela impossible d’armer les moteurs de nouveau, j’ai pas regardé en détail mais il voulait plus du tout même après avoir rebranché la batterie.

          Donc en gros je considère que c’est un appareil pas fiable et dangereux, je pense que je vais remplacer le mini-cube par un XJB F410 (de chez HGLRC). C’est un module équivalent avec un ESC 10A et j’aime bien les contrôleurs de cette marque.

          J’aurais peut être un meilleur résultat qu’avec le minicube qui me semble bien foireux (celui que j’ai en tout cas).

          1. J’en suis pas là et je n’ai pas le même recul que toi, c’est mon premier vrai drone, mais cela semble un peu limite. Déjà changé caméra, buzzer, un moteur, et surtout le récepteur. Je le trouve tout de même très sympa à piloter.
            Je te montrerai le montage pour l’osd si tu veux bien.

          2. yes, si tu veux. Envoie moi un lien avec des photos. Quand tu dis que ça passe pas c’est que l’OSD apparait pas ? Essaye de forcer dans Betaflight OSD le format PAL et après NTSC. Je viens de lire qu’un mauvais réglage du format faisait que l’OSD n’apparaissait pas.

  4. je t’envoie les photos ce soir
    en fait avec ce montage, le vtx ne s’allume même pas, donc pas du tout de vidéo. j’ai bien mis rouge noir, et bleu sur vtx et orange sur video de la caméra. et si je shunt le bleu avec le orange sans passer par la caméra et vtx, l’alimentation se fait.
    j’essaie ce soir dans bétaflight mais j’ai pas l’impression que cela vienne d’un probleme logiciel. est ce que mes branchements sont bons?

    https://www.banggood.com/fr/1_2g-Super-Light-1000TVL-14-CMOS-2_8mm-Lens-FOV170-Degree-Mini-FPV-Camera-p-1110381.html?rmmds=search
    https://www.banggood.com/fr/Eachine-VTX03-Super-Mini-5_8G-72CH-025mW50mw200mW-Switchable-FPV-Transmitter-p-1114206.html?rmmds=home-mid-recommendations

    1. Oui en effet, ca sent le problème de câblage. Je vais regarder en détail les specs et je te dis tout à l’heure

    2. J’ai regardé les composants, en principe ça devrait fonctionner. Truc bête, est-ce que tu as allumé le VTX3 ? (par défaut il n’émet pas selon la doc et peut être n’alimente pas la caméra (?)).

      en me basant sur la description des 3 composants (caméra, vtx et contrôleur Eachine Minicube) tu devrais avoir ce câblage :

      http://imgur.com/ZEHc826

      (nb : le fil blanc pour l’audio de la caméra n’est pas raccordé)

      1. Salut. Alors caméra pas mal du tout. Un rendu un peu moins bien que la tx03.
        Mais à nouveau des chutes sans aucune raison. Je n’y comprends plus rien. Je ne trouve pas la fonction hold pour le fail-safe dans betaflight.
        Tu me conseilles de changer de carte de vol ? Une carte en particulier ?

        1. Ah mince.

          Pour le failsafe. Dans le menu, je te conseille de mettre « hold » pour la commande « throttle » (dans le stage 1, partie de gauche, c’est un petit déroulant).

          pas vraiment de conseil pour le remplacement du mini-cube. Je me suis commandé un HGLRG (XJB) F410 pour remplacer sur le mien mais j’ai aucune idée du bon fonctionnement de la chose (pas reçu, pas testé. Je suis juste content des autres contrôleurs de la même marque) : https://www.banggood.com/20x20mm-XJB-F410-Dshot-Flytower-Micro-F4-AIO-OSD-BEC-Flight-Control-10A-Blheli_S-2-3S-4-In-1-ESC-p-1148282.html

          Après j’ai d’autres idées pour tenter de régler le problème de comportement anormal du Aurora. Notamment changer le protocole de communication des ESC dans Betaflight. Par défaut c’est DShot600 et donc éventuellement tester en multishot ou oneshot.

          1. Je vais essayer tout cela.
            Ca m’embete de perdre du temps avec les commandes qui durent 3 semaines, donc je regarder pour remplacer comme toi le controleur mais je pensais pas aux esc.
            penses tu qu’une mise a jour de betaflight pourrait y faire qchose?

          2. Tu peux toujours tenter la mise à jour. Moi j’ai des problèmes alors que je suis sur la dernière version (3.1.7).

            Si t’as le temps, tente le coup du changement de protocole pour les ESC. Ca peut résoudre le problème à moindre coût et sans perdre de temps.

Laisser un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.